Cloud Login Issue
Incident Report for Compsys Inc.
Resolved
This Citrix Licensing issue was corrected at roughly 3:30AM CST
We have tested it and confirmed that logins are now functioning properly.

All services are operational at this time but please reach out to our support team if you are continuing to experience any issues!
Posted May 24, 2024 - 08:55 CDT
Identified
We are currently experiencing an issue with Citrix Licensing that is affecting some users' ability to log in. Our team is actively investigating the root cause and working towards a resolution as quickly as possible.
Posted May 23, 2024 - 06:50 CDT
This incident affected: Cloud Servers (Citrix).